Een film maken in Archicad

Een film maken in Archicad

Een film is een serie van vaste 3D beelden, frames genaamd. Eén frame is óf het 3D venster óf een gerenderd beeld. Een film is daarom gebaseerd op de instellingen van één beeld onder het menu Image. Deze instellingen in combinatie met de Camera Tool (camera gereedschap) maken een film. Door camera’s op de plattegrond te plaatsen kan er een film gemaakt worden in Arhicad. Er wordt automatisch een pad gegenereerd tussen de geplaatste camera’s. Het pad en het aantal frames per seconde kunnen te allen tijden bijgestuurd worden.

Het plaatsen van de camera’s

  1. Ga naar de plattegrond
  2. en plaats een camera met behulp van de Camera Tool

of
  1. navigeer naar een beeld in 3D perspectief
  2. Open het 3D Visualization Palette: Window > Toolbars > 3D Visualization
  3. en plaats een camera met behulp van de functie 'Put a camera into the path' 

  1. Plaats vervolgens een tweede camera ( of meer) om er een film van te kunnen maken.
    Op het moment dat de tweede camera is geplaatst maakt Archicad automatisch een camerapad (Path) aan. Het pad wordt kenbaar gemaakt op de plattegrond met behulp van lichtgrijze lijnen.
Geplaatste camera’s zijn frames in de film, zogenaamde Key Frames. Tussen deze Key Frames interpoleert Archicad automatisch eigen ‘camera’s’. Deze frames hebben waardes die tussen de twee Key Frames in liggen. Plaats de benodigde Key Frames om het pad te bepalen.
Hoe meer camera’s er geplaatst worden des te meer controle er is over het pad, immers alle camera’s liggen op het pad.
Elke camera heeft een eigen nummer. De nummers zijn bepalend voor de richting van het pad: op het pad volgen de cameranummers elkaar op.

Het bewerken van het pad

  1. Selecteer een camera
    Deze geeft 3 punten:
    1. Met het middelste punt kan de camera verplaatst worden, het pad wordt dan automatisch verlegd

    2. Met de twee buitenste punten, handvaten, kan de vorm van het pad aangepast worden. Aan één zijde zit een haakje dat geeft de filmrichting aan.  Door een handvat te verleggen wordt het pad bewerkt. Bij een verlenging van het handvat wordt er meer prioriteit aan de vorm van het pad gegeven ter plaatse van de camera. Het is een soort raaklijn aan het pad.

  2. Verplaats de camera eventueel of pas de handvaten aan zodat het pad loopt zoals gewenst
Een aanpassing kan ook gedaan worden door het toevoegen van een extra camera. De nieuwe camera krijgt echter automatisch het hoogste volgnummer wat kan resulteren in een afwijkend pad. Selecteer de voorgaande camera, Kopieer deze en plak direct weer in het model . Er wordt nu automatisch een camera toegevoegd na de geselecteerde camera.
  1. Open de Camera Settings:
    1. Hier kan het camerapad, de film, hernoemd worden
    2. Geswitched worden tussen de verschillende camera's
    3. Het aantal frames dat dit camera standpunt getoond moet worden, kan hier aangegeven worden. Deze Key Frames zijn meestal mooie beelden en standpunten en kunnen de moeite zijn om wat langer bij stil te staan. Dus bij 0 gaat het beeld meteen door, bij bijvoorbeeld 10 blijft de film hier even stilstaan.
    4. Het pad teruggezet worden naar de beginwaarde, mochten de camerahandvaten bewerkt zijn
    5. De positie en kijk richting en hoek ingesteld worden
    6. De positie van de Zon gedefinieerd worden

      Zie voor meer informatie over de instellingen het artikel van GRAPHISOFT over de Camera Tool Settings.
  2. Open Path... (7):

    1. Hier kan ook de naam van het pad (film) aangepast worden
    2. Onder Motion Controls kan er bij Bezier of Polygon het pad als een kromme of rechte lijnen vormgeven worden
    3. Bij Closed of Open gesloten of open gemaakt worden; de laatste camera wordt respectievelijk niet of wel met de eerste verbonden.
    4. Bij Target definieert het pad de kijkpunten; Polygon maakt een hoekig kijkpuntpad, Smooth maakt een vloeiend kijkpuntpad.
    5. Onder Display Options kan gekozen worden wat er weergegeven moet worden op de plattegrond; niks, enkel de camera's, de camera's en het pad of ook nog het kijkpunt pad als voor de optie 'Everyting', gekozen wordt.
      Toon eventueel een fragment van het pad en kies de gewenste kleur. 


    6. Onder Motion Resolution kan bij 'In-between frames' het aantal automatisch door Archicad aan te maken frames tussen de geplaatste camera’s, de Key Frames bepaald worden.
Wanneer een gelijkmatige film gewenst is, dienen de camera’s ongeveer op een gelijke afstand van elkaar te staan. Moet een bepaald deel van de film langzamer getoond worden, dan moeten daar extra camera’s geplaatst worden. Normaal gesproken bevat een animatie 25 frames per seconde. Het maximum wat hier als tussenliggende frames opgegeven kan worden is 100. Onderin (g) wordt het totaal aantal frames getoond. Hieruit kan opgemaakt worden hoelang de totale film zal duren.
Kies tijdens het tekenen voor None onder Display Options; het pad en de camera’s worden nu tijdelijk van de plattegrond gehaald wat prettig tekent.
  1. Klik als alles naar wens is op 'OK'
  2. en vervolgens op 'Apply...'
Kies Path Options om de instellingen achteraf aan te passen.
Reken in eerste instantie de film een keer door met een lage waarde voor de In-between frame, zodat het pad, de verhoudingen en de snelheid gecontroleerd kunnen worden.

Het doorrekenen van de film

Als het pad en de camera’s naar wens zijn, kan de film worden doorgerekend:
  1. Ga naar Document > Creative Imaging >Create Fly-Through
    In de geopende interface kunnen onder Source instellingen gemaakt worden met betrekking tot de frames.
    1. Kies of de beelden gebaseerd zijn op het 3D venster of gerenderde beelden.
      Hiervoor is er eerder onder het menu Image respectievelijk de 3D Window Settings… of de PhotoRendering Settings… ingesteld.
    2. Kies of de Keyframes only of ook de In-between frames meegenomen moeten worden
    3. Vink aan of alle frames of een gedeelte in de film opgenomen moeten worden. 
      Er kan steeds een gedeelte van de frames gerenderd worden door te kiezen voor 'Frames from'.
Reken een gedeelte van de film uit als er twijfel is over het resultaat in een specifiek gedeelte. Dit spaart tijd.


Onder 'Result' kan het formaat bepaald en kleur bepaald worden:
  1. Kies de extensie van de film; Er kan gekozen worden voor Movie Files of losse frames. Dit aan de had van met welke software de film wordt afgespeeld of verder bewerkt moet worden. 
  2. Vervolgens kan gekozen worden of de film al dan niet in kleur uitgevoerd moet worden
  3. Bij het kiezen voor 'MP4 Movie Files' of 'QuickTime Movie Files' komt de optie 'Frame rate:' beschikbaar (standaard 25 beelden per seconde)
  4. Klik op de knop 'Show' om de film te bekijken alvorens deze op te slaan
Vraag de klant in welk formaat ze de film willen ontvangen of lever een film aan die zichzelf afspeelt, bijvoorbeeld met behulp van http://www.radgametools.com/bnkdown.htm
  1. Klik op 'Save…' en kies de locatie waar het bestand opgeslagen mag worden
Zie voor meer informatie over de instellingen het artikel van GRAPHISOFT over het maken van een Fly-Through.

Aanvullende tips en aanwijzingen:

  1. De zon kan per camera worden ingesteld door de zon aan de camera te verleggen.
  2. Met behulp van Roll Angle in de Camera Settings (Camera Tool) kan de camera onder een hoek gebracht worden wat een meer dynamisch beeld en film teweeg brengt.

  3. Films kunnen ook in Schetsstijl gerenderd worden door in de PhotoRendering Settings… (Document > Creative imaging) bij 'Engine:' voor 'Sketch' te kiezen.
  4. Een preview op de film is mogelijk met het 3D window als source en een lage waarde voor In-between frames om het pad te controleren:
    1. Stel onder Source de optie 3D Window in
    2. Klik op Save….
      De film wordt nu versneld uitgerekend en eventuele ‘fouten’ worden zichtbaar voordat de film helemaal doorgerekend is.

  5. Om te voorspellen hoe lang het doorrekenen van de film duurt kan een representatieve camera (Key Frame) als een statisch beeld gerenderd worden (Document > Creative imaging > PhotoRender Projection). De hiervoor benodigde tijd vermenigvuldigt met het totaal aantal frames geeft de definitieve rekentijd.
  6. Voordat de film wordt gecomprimeerd, worden eerst alle frames als statische beelden gebufferd wat capaciteit vraagt.
  7. Stel kritische vragen bij de tijdsduur van een film
    1. Hoe lang wil ik de klant vermaken?
    2. Is het vermakelijk?
    3. Wat mag de bestandsgrootte van de film zijn? 
    4. Ga ik de film mailen of op andere manier versturen of aanbieden
  1. De grootte in maateenheid van de film is in pixels. Voor een presentatie op een beeldscherm is 1024x768 al een groot formaat. Voor een beamer is 640x480 een goed formaat. Dit kleinere formaat scheelt aanzienlijk in bestandsgrootte en doorrekentijd.
  2. De pixels worden voor:
    1. een film met het 3D venster als uitgangspunt ingesteld in de View Settings ( klik met de rechtermuisknop op de tab van de 3D view en kies voor View Settings)
    2. een film met gerenderde beelden onder Document > Creative Imaging > PhotoRendering Settings

    • Related Articles

    • Archief - Verschil template Archicad 23 en 24 (KME) BE

      In dit artikel worden de wijzigingen in de Archicad 24 BE (KME) template ten opzichte van de Archicad 23 BE (KME) template aangegeven. Hierdoor is het makkelijker de beslissing te nemen of de huidige Archicad 23 bureautemplate (of delen hiervan) ...
    • Archief - Verschil template Archicad 23 en 24 (KME) NL

      In dit artikel worden de wijzigingen in de Archicad 24 NL(KME) template ten opzichte van de Archicad 23 NL(KME) template aangegeven. Hierdoor is het makkelijker de beslissing te nemen of de huidige Archicad 23 bureautemplate (of delen hiervan) ...
    • Een indicatieve daglichtberekening maken in Archicad

      Dit artikel geeft informatie over hoe een indicatieve daglichtberekening kan worden opgezet in Archicad. Dit met behulp van Archicad Properties, Expressions en vooringestelde Schedules in de KeyMember template.  Indien de toegelichte methodieken ook ...
    • Archief - Een bestaand project of template omzetten naar Archicad 24

      Archicad 24 worden een aantal nieuwe werkmethodieken en features geïntroduceerd gericht op de afstemming van het ontwerp met constructeurs en installateurs. Voor de migratie moeten daarom indien van deze features gebruik gemaakt zal worden vooral ...
    • Zelf een bureautemplate maken

      Om elk Archicad project te beginnen met de eigen bureau-instellingen (lagen, pennen, arceringen, masters met eigen bureaustempel, enzovoort) kan een template (startbestand) aangemaakt worden. Aangezien de elementen in de Archicad-bibliotheek gebruik ...