Experimentele functies

Experimentele functies

Experimental Features

GRAPHISOFT wil graag een korter ontwikkelproces realiseren en in een vroeg stadium feedback uit de markt verzamelen. Gebaseerd op deze feedback zullen deze experimentele functies in de toekomst wel of niet in Archicad verwerkt gaan worden. 

Experimentele functies kunnen aan of uit worden gezet in de werkomgeving via Work Environment > More Options > Experimental Features.
GRAPHISOFT verzamelt anonieme gebruikersgegevens via het Customer Experience Improvement Program (CEIP) om de bruikbaarheid van de functies te analyseren. Standaard wordt bij een nieuwe installatie een melding gegeven waarin aangegeven wordt of informatie verzameld mag worden. Als een Experimentele functie wordt aangezet en er was nog geen toestemming gegeven zal deze vraag herhaald worden. Het is niet verplicht dit aan te zetten. 

Constructief analytisch model in IFC formaat

Het is mogelijk om een constructief analytisch model in IFC formaat te openen en/of op te slaan. Zet deze functie eerst aan bij Work Environment > More Options > Experimental Features. 'Enable IFC Structural Analysis Model Import-Export'
Indien er een keuze is tussen het SAF formaat en het IFC formaat kan het beste het SAF formaat gebruikt worden aangezien het SAF formaat wijzigingsprocessen in het model ondersteund door het gebruik van de Model Compare.  

Openen

  1. Kies via File > Open het formaat 'IFC structural Analysis View'.
    Bij het open zullen elementen van het Structural Analytic Model (SAM) worden geconverteerd naar Archicad gereedschappen. Datgene dat wordt getoond is zo exact mogelijk het originele constructieve model. 
Een ontvangen constructief analytisch model is met een viewer zoals BIMcollab ZOOM te bekijken. Hiermee is te controleren of de informatie overeenkomt.

Opslaan

De export is gebaseerd op de 'IFC Structural Analysis View' (volgens BuildingSMART).
  1. Kies bij File> Save as voor 'IFC Structural Analysis View'
  2. Kies bij het opslaan voor het gehele project of alleen zichtbare delen




JSON/Python API for Archicad

GRAPHISOFT  introduceert vanaf Archicad 24 een nieuw soort API (Application Programming Interface) dat zich richt op het creëren van geautomatiseerde scripts en complexe commando's buiten Archicad door gebruik te maken van een hoger niveau programmeertaal. Tijdrovende taken worden hiermee geautomatiseerd.
De technologie is gebaseerd op het gestandaardiseerd gegevensformaat, JSON (JavaScript Object Notation), waarin C++ commando's stapsgewijs vertaald zullen worden om een nieuw niveau van programmeren mogelijk te maken.

Vanaf Archicad 24 zullen de volgende gebieden toegankelijk zijn via JSON:

  1. Aanpassing van door de gebruiker gemaakte en standaard reeds beschikbare Archicad properties van elementen
  2. Aanpassing van onderdelen in de Navigator en toegang tot de automatiseringsprocessen van documenten. (nog deels in ontwikkeling)
Doordat JSON een taal-onafhankelijk dataformaat is, wordt het mogelijk om een groot aantal programmeertalen te gebruiken zoals Python of Perl. Om de wereldwijde gebruikers van Python te ondersteunen is een 'Python wrapper' gemaakt en zijn alle beschikbare commando's in Python gedocumenteerd.

Functie gebruiken

  1. Zet de functie aan in de werkomgeving via Work Environment > More Options > Experimental Functions.
  2. Installeer Python versie 3.6 of hoger: https://www.python.org/
  3. Installeer de Archicad CAD - Python connectie
    Dit gebeurt automatisch nadat Python is geïnstalleerd. Mocht de connectie niet goed gaan klik dan op de instellingen (wiel icoon) en kies voor 'Update Connection'.  

Nieuw in Python? Lees hier een beginners gids: https://wiki.python.org/moin/BeginnersGuide

Python Palette gebruiken

Om het gebruik van deze nieuwe functionaliteit te vereenvoudigen is een Python Palette gemaakt in de Archicad interface. Het palet kan worden gebruikt om Python scripts the importeren, uitvoeren en beheren vanuit Archicad.  Het palette kan worden opgeroepen via Window > Palettes > Python Palette, nadat de experimentele functie is aangezet in de werkomgeving.



Overlap bij Lineaire elementen controleren

Voer een modelcontrole uit voordat de documentatie gemaakt wordt door lineaire elementen (wanden, kolommen, liggers, lijnen, polylijnen) te identificeren waarvan de referentielijnen gedeeltelijk of volledig overlappen. Eventuele overlappingen worden geïdentificeerd en gemarkeerd als problemen, zodat ze indien nodig gemakkelijk te vinden en corrigeren zijn.
Het is ook mogelijk om te controleren op duplicaten. Daarvoor wordt de feature 'check duplicates' gebruikt. Het verschil is dat bij de modelcontrole voor overlap bij lineaire elementen ook gedeeltelijke overlappingen gevonden worden. 
Zet de functie aan bij Work Environment > More Options > Experimental Functions. Enable Overlap Check for Linear Elements. 

Functie gebruiken

  1. Ga naar Edit > Check Linear Overlaps om het palet 'Lineaire overlappingen controleren' te openen.
  2. Kies welk deel van het model gecontroleerd moet worden: de huidige View of een selectie/Marquee. 
  3. Activeer de gereedschapspictogrammen om te bepalen welke element-paren moeten worden gecontroleerd: Muren vs muren, kolommen vs kolommen, 
    balken vs balken en/of lineaire 2D-elementen.
  4. Kies voor 'Start Check...'
  5. Open de Issue Organizer om de resultaten te bekijken
    Ga hiervoor naar Document > Issue Organizer
  6. Dubbelklik op een issue om het te bekijken in de Issue Manager (Document > Issue manager
    Navigeer naar de oplichtende elementen en pas het model aan waar nodig. 

  7. Klik 'Recheck' om de controle opnieuw te doen. Alle opgeloste problemen zullen automatisch verwijderd worden uit de issue manager. 
De optie 'Recheck' blijft actief totdat het project gesloten wordt. 

Extra opties

Niet-botsende elementen overslaan
In sommige gevallen kunnen twee elementen overlappende referentielijnen hebben, maar ze botsen niet echt in 3D. Om dergelijke problemen te negeren, moet de optie 'Skip Elements if they are not colliding in 3D' aan staan.


Automatic Issue Naming 
Namen van issues worden standaard gemaakt op basis van het elementtype en worden genummerd. Gebruik optioneel 'Custom Name' om de naamgeving aan te passen. Alle gemaakte issues hebben dezelfde aangepaste naam en zijn genummerd. Wijzig indien nodig de naam van een Issue in de Issue Organizer.



De mogelijkheid om Archicad Properties te importeren en exporteren via Excel is een functie die al langer beschikbaar is in Archicad. Maak een Schedule met daarin opgenomen de Archicad Properties, waarvoor data input gewenst is. Exporteer dit naar Excel en stuur het naar een externe partij. Deze externe partij (een adviseur of constructeur) vult de benodigde waarden in en stuurt het Excel bestand terug. Na import van het Excel bestand worden de waarden automatisch ingevuld in de Archicad Properties. Voorheen was deze werkmethodiek beperkt tot de Properties van elementen in het hoofdbestand. De Properties van eventuele Hotlinked Modules werden niet ingevuld. Deze werkmethodiek is verbeterd vanaf Archicad 25. Activeer deze experimentele functie en Update alle Properties voor elementen in het hoofdbestand. Ook als deze onderdeel zijn van een Hotlinked Module. 

Activeer de functie

Deze experimentele functie van Archicad 25 kan worden geactiveerd via Options > Work Environment > More Options > Experimental Features.


Voorgestelde werkmethode

  1. Open het Archicad hoofdbestand en Update alle Hotlinked Modules (als het een Teamwork bestand betreft doe dan ook een Send and Receive actie).
  2. Sla een Interactive Element Schedule op dat gebruikt gaat worden voor de data uitwisseling
  3. Gebruik het commando 'Export Property Values from Schedule' (File > Interoperability > Classifications and Properties) en exporteer naar Excel
  4. Vul in Excel de missende of gewijzigde data in (of door externe adviseur/ constructeur etc.)
  5. Gebruik het commando 'Import Property Values from Schedule' om de nieuwe data te importeren
a. Property waarden worden eerst geüpdatet in de elementen van het hoofdbestand
b. Als het hoofdbestand Hotlinked Modules bevat die geüpdatet moeten worden kies dan voor 'import into modules' in het pop-up venster

De voortgang van dit proces kan tijdelijk worden onderbroken en hervat:




Dark mode voor Mac

De mogelijkheid om de weergave op donker in te stellen, is beschikbaar vanaf macOS Mojave (10.14.). In de donkere modus wordt het kleurenschema donkerder gemaakt, zodat de inhoud waaraan gewerkt wordt meer opvalt, terwijl vensters en regelaars op de achtergrond lijken te verdwijnen.
Archicad zal zijn uiterlijk aanpassen op de gewenste instelling met donkere iconen en een donkere gebruikersinterface.
  1. Zet deze functie aan bij Work Environment > More Options > Experimental Functions
  2. Kies op de Mac Apple-menu  > 'Systeemvoorkeuren' en klik op 'Algemeen'
  3. Kies voor 'Donker' of 'Automatisch'
Om een volledige donkere werkomgeving te krijgen kan de achtergrond van de werkvenster donker ingesteld worden via View > Grid & Editing Plane Options > Grids &
Background. Met een aangepaste PenSet ( Options > Element Attributes > Pens & Color)  kan de zichtbaar van de lijnen beïnvloed worden.



    • Related Articles

    • Archief - Nieuwe features in Archicad 24

      Een overzicht van alle nieuwe functies in Archicad 24 Archicad 24 maakt het mogelijk om als multidisciplinair team optimaal samen te kunnen werken in een volledig open cloud-omgeving. Ontwikkelingen in zowel Archicad, BIMcloud en BIMx maakt ...
    • Productiviteitsverbeteringen in Archicad 24

      Nieuwe meubelen  Vanaf Archicad 24 zijn in de bibliotheek meubelen bestemd voor woonfuncties uitgebreid en verbeterd.  De verbeterde gebruikersinterface maakt het eenvoudiger om deze nieuwe en moderne bibliotheekobjecten in te stellen en te plaatsen ...
    • Constructief design met Archicad

      Constructief ontwerpen met Archicad Ondanks de voortdurende ontwikkelingen in digitale ontwerptools, vertrouwt de bouwsector nog steeds grotendeels op oude workflows. Verschillende disciplines werken afzonderlijk en wisselen gegevens alleen uit, ...
    • Nieuwe features in Archicad 26

      Szervita Square Building | DVM Group, dvmgroup.com, Hungary Een overzicht van de nieuwe functies en mogelijkheden in Archicad 26 met links naar de uitgebreide uitleg. voor meer ins en outs inzake Archicad 26 en installatie, migratie en vernieuwde ...
    • Nieuwe features in Archicad 25

      Signature building - Duke Ellington Een overzicht van de nieuwe functies en mogelijkheden in Archicad 25 met links naar de uitgebreide uitleg.  Ontwerp Uitbreiding 2D-3D navigatie Elementen blijven geselecteerd wanneer er van venster gewisseld wordt ...