Programma van Eisen add-on

Programma van Eisen add-on

Met de Programma van Eisen add-on kan eenvoudig een programma van eisen worden ingelezen vanuit een Excel- of Numbers-bestand, waarbij automatisch de verschillende ruimten als Zones in het model worden geplaatst. De Zones die dan gecreëerd worden kunnen dienen als uitgangspunt voor het ontwerp en/of als controle om te valideren of het model aan de gevraagde eisen voldoet.

Vanaf de KeyMember Editie van Archicad 21 worden met de installatie van de KeyMember Editie alle benodigde bestanden geïnstalleerd. De add-on is beschikbaar vanuit het menu 'KeyMember'.

Een demonstratie van de add-on en een kostenraming wordt getoond in het  ArchiCafé van oktober 2020 vanaf het tijdstip 41:12

Er kunnen meerdere Zones in één keer geplaatst worden, inclusief:
  1. Categorie code (ruimte gebruik)
  2. Oppervlakte
  3. Minimale breedte
  4. Bezettingsnorm
  5. Geluidsnorm
  6. Ontwerptemperatuur
  7. Eenheidsprijzen
  8. Eigen teksten en/of waardes (bijvoorbeeld voor inventaris of extra eisen)
Verdere mogelijkheden die deze add-on biedt:
  1. Automatische nummering
  2. Automatisch juiste categorie en plaatsing op de gewenste verdieping
  3. Geplaatste Zones kunnen in alle bouwfases gebruikt worden
  4. De oorspronkelijke oppervlakte-eis blijft oproepbaar
  5. Schedules met betrekking tot Kostenraming, bezetting Norm en Ontwerp en Programma van Eisen kunnen in Archicad  opgeroepen worden
  6. Gegevens uit de PvE add-on kunnen opgenomen worden in de Zone Stempel KM
In dit artikel wordt stap voor stap uitgelegd hoe de add-on werkt, met daarnaast een uitleg hoe daarna verder en oplossingen voor de eventuele foutmeldingen.
Voor uitgebreide uitleg over hoe de Zone stempel KM werkt wordt verwezen naar het artikel instellingen Zonestempel KeyMember Editie.

Stap 1 - Invullen Excel bestand

  1. Open het bestand ‘Programma van Eisen Template.xls' (Windows) of’ Programma van Eisen Template.numbers' (Apple)
    Deze zijn te vinden in de map GRAPHISOFT > Archicad xx > Archicad xx modules KME NL/BE > Programma van Eisen > Programma van Eisen Template NL/BE.xls. 
  2. Maak een keuze tussen één van de twee werkbladen: Eenvoudig of Uitgebreid
  3. Vul de cellen in conform de instructies in de eerste vijf rijen
    In principe is alleen de kolom 'Oppervlakte' verplicht om in te vullen. Zie voor uitgebreide instructies het hoofdstuk ‘Toelichting invullen template’. 
Verander in géén geval de eerste zes rijen van het excel bestand. Voeg geen kolommen of rijen toe! De add-on heeft deze exacte notaties nodig om goed te kunnen werken.
Het is mogelijk om data uit een ander document eerst te kopiëren + plakken en zonodig daarna het datatype aan te passen. Ook kunnen formules of verwijzingen gebruikt worden in de template om het overbrengen van data uit een ander document te vergemakkelijken. Bij het exporteren wordt namelijk alleen de waarde in de cel, niet een formule, meegenomen.

Stap 2 - Exporteer naar CSV

De Programma van Eisen-add-on kan enkel CSV bestanden lezen. Dit staat voor Comma Separated Value, waarbij de kolommen herkenbaar zijn aan een komma. Zowel Excel(Windows) als Numbers (Apple) kunnen dit bestandsformaat exporteren.

Excel (Windows)

  1. Ga naar Bestand > Opslaan als

  2. Kies onderin voor het formaat 'CSV (gescheiden door lijstscheidingsteken)' of voor 'CSV UTF-8 (komma's gescheiden) (*.csv)'


  3. Bij het opslaan komt Excel met een melding dat met CSV niet meerdere tabbladen opgeslagen kunnen worden. Klik op 'OK'.


  4. Daarna komt er nog een melding dat CSV niet alle (in dit geval overbodige) functies van Excel kan bevatten. Kies voor 'Ja'. 


  5. Sluit het bestand in Excel
    Anders kan het CSV bestand niet worden geïmporteerd.

Numbers (Apple)

  1. Ga naar Archief > Exporteer naar > CSV… 


  2. Selecteer een locatie voor de aan te maken map
    Beide werkbladen worden tegelijkertijd geëxporteerd in deze map en hebben de naam van het bestand.

Stap 3 - Importeer Programma van Eisen

  1. Open Archicad en stel het Archicad bestand goed in:
    1. De 'Default Zone Categorie' (instelling van het Zone-gereedschap) moet een categorie zijn gekozen waaraan de 'Zone stempel xx KM' gekoppeld is.
      Bij gebruik van de Archicad 21 NL/BE KME template of nieuwer is dit standaard goed ingesteld.
    2. Zorg voor voldoende verdiepingen in het Archicad project
      Minimaal het aantal als (eventueel) genoemd in het PvE.
    3. Zorg dat laag waarop de Zones geplaatst worden (Z Ruimtefuncties) aanstaat

  2. Ga naar het menu KeyMember > Importeer Programma van Eisen
    Er verschijnt een dialoogvenster worden geopend om naar het CSV bestand te zoeken

  3. Kies het bestand en bevestig
    Bekijk het resultaat

  4. Kies voor 'Create Zones'
    De Zones worden geplaatst




Toelichting invullen template

Het bestand bevat een eenvoudige template en ook een uitgebreide template. De eenvoudige template bevat vier kolommen om in te vullen en de uitgebreide template heeft nog aanvullende kolommen die meer mogelijkheden bieden:

Invoer eenvoudige en uitgebreide template

  1. Nummer
    Vul indien bekend een nummer van de ruimte in. Als deze cel blanco is, zal Archicad  de Zone zelf nummeren vanaf 0.01. Als ls er één of meerdere Zone-nummers zijn gedefinieerd zal Archicad  de niet genummerde Zones voorzien van het Zone-nummer x.xx.
    Indien een verdieping is ingevuld, worden eerst de verdiepingen gesorteerd en dan genummerd met de verdiepingsnotatie voor het nummer: eerste verdieping wordt dan bijvoorbeeld: 1.03
In deze cellen dient een punt gebruikt te worden, geen komma.
  1. Naam
    De naam van de Zone 
  2. Aantal
    Het aantal van de ruimtes kan worden ingevuld. Er worden zoveel identieke Zones geplaatst als hier is ingevuld.
  3. Oppervlakte (Verplicht!)
    De (netto) oppervlakte moet hier worden ingevuld. De add-on zal een vierkante Zone plaatsen met deze oppervlakte. Indien een breedte is ingevuld kan een rechthoekige Zone worden geplaatst.

Invoer uitgebreide template

  1. Verhouding Bruto/Netto
    Soms kan een Programma van Eisen enkel de netto oppervlakte bevatten. Er kan dan een bruto/netto verhoudingsfactor ingevuld worden zodat de Zone groter wordt. (voorbeeld 1,1, dit zal de Zone 10 procent groter maken)
  2. Breedte
    Hier kan een breedte worden opgegeven. Één zijde krijgt dan deze breedte en de andere zijde is het oppervlakte gedeeld door deze breedte. Is dit veld blanco, dan ontstaat er een vierkante Zone.
  3. Hoogte
    Hier kan de hoogte van de ruimte worden ingevuld. De Zone wordt dan ‘unlinked’, er wordt een absolute hoogte ingevuld. Is dit venster blanco, dan wordt de Default waarde gebruikt (bijvoorbeeld Offset -200)
Alle afmetingen in meters (komma als scheidingsteken)
  1. Verdieping
    Hier kunnen de verdiepingen worden aangegeven. Er worden geen nieuwe verdiepingen aangemaakt.
  2. Zone Categorie
    Hier kan de categorie code worden ingevuld. Dit is de code die bij het attribuut Zone Categories kan worden ingevuld. Op basis van deze code wordt de bijbehorende Categorie gezocht. Eventueel kan de code inclusief categorie worden ingevuld, gescheiden door een spatie. 
Het is van belang dat aan iedere gekozen Categorie de Zone stempel xx KM  is gekoppeld. Dit kan via Options > Element Attributes > Zone Categories of via de Attribute Manager
  1. Bezetting Norm (1) / Bezetting Norm (aantal personen) (2) / Bezetting Ontwerp (3) / Bezetting Ontwerp (aantal personen) (4)
    Deze waarden kunnen automatisch ingevuld worden in de Zonestempel. Daarmee kan vervolgens gecontroleerd worden of een ruimte aan een norm voldoet of om de bezetting van een ruimte te berekenen. Lees hierover meer in de het artikel Instellingen Zone-stempel KeyMember Editie


  2. Prijs per m2 / Prijs per m3
    Deze waarden kunnen automatisch ingevuld worden in de Zone-stempel. 


  3. Temperatuur / Geluid 
    Deze eigenschappen kunnen worden ingevuld in Archicad  properties. Deze Archicad properties moeten van te voren wel aanwezig zijn in het project. Als het project gestart is met de de Archicad  - - NL/BE KME template, zijn deze automatisch aanwezig.
     

  4. Eigen tekst 1 / Eigen tekst 2 / Eigen tekst 3 / Eigen waarde 1 / Eigen waarde 2 / Eigen waarde 3
    Deze eigenschappen kunnen worden ingevuld in de Archicad properties. Deze Archicad properties moeten van te voren wel aanwezig zijn in het project. Als het project gestart is met de de Archicad - - NL/BE KME template, zijn deze automatisch aanwezig.

Verwerken van de Zones

De Zones kunnen nu verder worden verwerkt als normale Zones. Ze kunnen verplaatst worden, de vorm kan worden aangepast of de weergave instellingen kunnen worden veranderd. De Zones behouden hun originele oppervlakte.

Toon het PvE-oppervlakte in een Schedule

Het oppervlakte van de geïmporteerde Zones kan in een Schedule ook worden getoond om te vergelijken met het werkelijke oppervlakte.
  1. Open de Scheme Settings van een Schedule met Zones (bijvoorbeeld 'Zones m2 per verd')
  2. Bij Fields klik op het pijltje naast Add
  3. Kies Library Part Parameters

  4. Navigeer naar het Zone-object 'Zone Stempel XX KM'
  5. Zoek de parameter met variabel 'OorspronkelijkOppervlakteAddOn' met de naam 'Oppervlakte ingevuld door PvE Add-on'
  6. Voeg deze toe met de knop >>Add>>

  7. Pas de Schedule verder naar wens aan  

Wijzigen oppervlakte

Het is niet mogelijk de oppervlakte in Archicad te veranderen na het importeren. Indien de oppervlakte toch veranderd dient te worden, kan de volgende werkmethodiek gebruikt worden:
  1. Exporteer de eerder geïmporteerde schedule (File > Interoperability > Classifications and Properties > Export Property Values from Schedule)
  2. Pas de informatie aan in Excel of andere pakket en sla weer op als XLS
  3. Importeer de schedule weer (File > Interoperability > Classifications and Properties > Import Property Values into Elements)

Aanpassen Zone naar vorm wanden

Indien er in een later stadium wanden rondom de Zone zijn geplaatst, kan de Zone zich aan deze vorm aanpassen. Selecteer de Zone(s) en schakel van de handmatige constructiemethode (A) naar de Automatisch Constructie methode (B/C). Bevestig daarna dat de Zones geüpdatet moeten worden. Voor meer informatie over het werken met het Zone-gereedschap, bekijk de Tip & Truc De werking van het Zone-gereedschap
 

Omzetten in morph

Het is mogelijk om de Zones te gebruiken als basis voor een ontwerp. Plaats de Zone op de gewenste manier en maak een kopie naar een andere laag. Selecteer de Zones en kies in het rechtermuisknop-menu Convert to Morphs. Om alle resulterende Morphs om te zetten naar één vorm, kies Design > Morphs Extras > Union.

  

Foutmeldingen

Volg deze instructies exact op om foutmeldingen te voorkomen:
  1. Alle afmetingen in meter of m2 (komma als scheidingsteken)
  2. Alle getalnotaties met komma’s (behalve bij Zone-nummers)
  3. Teksten maximaal 255 tekens

‘Er is geen correcte template gebruikt’

Deze melding verschijnt als de add-on niet de juiste gegevens vindt in regel 6. Deze regel mag niet veranderd worden. Pas deze weer aan volgens de originele template voor het Programma van Eisen.

‘Zones kunnen niet worden geïmporteerd’

In de Preview verschijnen rode regels en de knop ‘Create Zones’ is uitgegrijsd. Dit komt doordat de add-on niet-toegestane input vindt. Let goed op dat in de cellen de juiste gegevens staan. Boven de kolom staat Tekst / Getal / Getal (geheel getal) en vul deze opmaak in.

‘Er is een probleem met het inlezen van het .csv-bestand’

  1. Het .csv-bestand dient eerst in Excel te worden afgesloten
  2. Controleer of de juiste template is gebruikt.

‘Zones zijn niet zichtbaar na importeren’

  1. Controleer of alle lagen voor de Zones aanstaan

    • Related Articles

    • Instellingen van de Zone-stempel KeyMember Editie

      Dit artikel gaat over de instellingen van de Zone-stempel van de KeyMember Editie. Voor algemene instellingen van de Zone en het plaatsen van de Zone, lees het artikel over de werking van het Zone-gereedschap. Een korte demonstratie van de ...
    • Archiveren van een project

      Een Archicad projectbestand (*.pln) bevat vaak koppelingen naar externe bestanden (onder andere bibliotheekelementen). Wanneer een bestand naar een andere partij verstuurd wordt (bijvoorbeeld de helpdesk) of na een aantal jaren weer geopend wordt ...
    • De werking van het Zone-gereedschap

      Het Zone-gereedschap is een zeer uitgebreid gereedschap en kan gebruikt worden voor zowel eenvoudige als complexe taken in kleine of grote projecten. In dit artikel wordt de werking van het Zone-gereedschap beschreven.  Voor meer informatie over de ...
    • Uitwisseling in IFC op basis van de Hulpfiche BIM-modelleerafspraken

      In het OpenBIM proces is het uitwisselen van digitale bouwinformatiemodellen tussen de verschillende projectpartners (aannemers, architecten, … ) een belangrijk aspect. Deze modellen moeten eenvoudig samen te voegen en te coördineren zijn, zodat ze ...
    • Schedules maken

      Met Archicad kunnen eenvoudig lijsten of stuklijsten gemaakt worden van alle gegevens in het model. Deze zogenaamde Interactieve Schedules blijven aan het model gekoppeld. Alles wat in de Schedules wordt gewijzigd, wordt direct in het model ...